aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHugo Lima <hugo.lima@openbossa.org>2010-01-25 14:30:24 -0200
committerHugo Lima <hugo.lima@openbossa.org>2010-01-25 14:36:08 -0200
commit56ef82ec2648e0f55232e8b004be60d4ea785db5 (patch)
tree621a39f0b85dbd2b40fc5f4b0b9cef064909b148 /CMakeLists.txt
parent0c0c256c244ce171151a0dac2e444912bb1f9692 (diff)
Shiboken generator doesn't need to link against QtXml and libapiextractor as informed by "ldd -u"
and confirmed by "ldd -r". Reviewed by Marcelo Lira <marcelo.lira@openbossa.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 2 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 870f8adf4..b34d62fec 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -48,20 +48,16 @@ shibokengenerator.cpp
include_directories(${CMAKE_CURRENT_SOURCE_DIR}
${APIEXTRACTOR_INCLUDE_DIR}
- ${APIEXTRACTOR_INCLUDE_DIR}/..
${GENERATORRUNNER_INCLUDE_DIR}
- ${GENERATORRUNNER_INCLUDE_DIR}/..
${QT_INCLUDE_DIR}
${QT_QTCORE_INCLUDE_DIR}
- ${Boost_INCLUDE_DIR})
+ ${Boost_INCLUDE_DIR})
add_library(shiboken_generator SHARED ${shiboken_SRC})
target_link_libraries(shiboken_generator
- ${APIEXTRACTOR_LIBRARY}
${GENERATORRUNNER_LIBRARY}
- ${QT_QTCORE_LIBRARY}
- ${QT_QTXML_LIBRARY})
+ ${QT_QTCORE_LIBRARY})
add_executable(shiboken main.cpp)
target_link_libraries(shiboken ${QT_QTCORE_LIBRARY})