aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMarcelo Lira <marcelo.lira@openbossa.org>2009-08-27 19:29:27 -0300
committerHugo Lima <hugo.lima@openbossa.org>2009-08-28 14:16:38 -0300
commit6aebdfc467fb3a6436f418875d974542519666b0 (patch)
tree5f755d3f07ae0b287c6093286a5556a8e458e082 /CMakeLists.txt
parent7170eba0ae3b8c1017b08161e827894f6afa6693 (diff)
added convenience binary applications to call the generatorrunner
with --generatorSet parameter for shiboken
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6641513fa..28470eb94 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -35,6 +35,9 @@ target_link_libraries(shiboken_generator
${QT_QTXML_LIBRARY}
-lgenrunner) # FIXME libgenrunner needs a cmake FindPkg script!
+add_executable(shiboken main.cpp)
+target_link_libraries(shiboken ${QT_QTCORE_LIBRARY})
+
# uninstall target
configure_file("${CMAKE_CURRENT_SOURCE_DIR}/cmake_uninstall.cmake"
"${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake"
@@ -47,17 +50,14 @@ enable_testing()
add_subdirectory(libshiboken)
add_subdirectory(tests)
-# "make dist", in fact "make package_source"
-#set(CPACK_SOURCE_PACKAGE_FILE_NAME "shiboken-${shiboken_VERSION}")
-#set(CPACK_SOURCE_GENERATOR TGZ)
-#set(CPACK_SOURCE_IGNORE_FILES "~$" ".svn" "debian/" "build/" ".swp$" "*.kdev4")
-#include(CPack)
-
set(ARCHIVE_NAME ${CMAKE_PROJECT_NAME}-${shiboken_VERSION})
add_custom_target(dist
COMMAND git archive --prefix=${ARCHIVE_NAME}/ HEAD
| bzip2 > ${CMAKE_BINARY_DIR}/${ARCHIVE_NAME}.tar.bz2
WORKING_DIRECTORY ${CMAKE_SOURCE_DIR})
+add_dependencies(shiboken shiboken_generator)
+
install(TARGETS shiboken_generator DESTINATION ${LIB_INSTALL_DIR})
+install(TARGETS shiboken DESTINATION bin)