aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLauro Neto <lauro.neto@openbossa.org>2009-11-10 11:07:44 -0300
committerHugo Lima <hugo.lima@openbossa.org>2009-11-10 19:35:19 -0200
commit94e356425a022e787d86007061977bc4aa01e413 (patch)
tree26eab63788c7093a7c17f5e8a2e72ab28d6bdf43 /CMakeLists.txt
parent81abd420131ed0897f8b21b6c21d6cffb6c68181 (diff)
Sorting overloads topologically
Instead of using the current weight-based overload sorting, sort them topologically based on implicit conversions. Reviewed by Hugo Parente <hugo.lima@openbossa.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d06f6a79a..d050dd408 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -5,6 +5,7 @@ cmake_minimum_required(VERSION 2.6)
find_package(Qt4 4.5.0 REQUIRED)
find_package(ApiExtractor REQUIRED)
find_package(GeneratorRunner REQUIRED)
+find_package(Boost COMPONENTS graph REQUIRED)
add_definitions(${QT_DEFINITIONS})