aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Hills <chaz@chaz6.com>2009-08-31 19:27:58 +0200
committerMarcelo Lira <marcelo.lira@openbossa.org>2009-08-31 17:48:48 -0300
commitae6e4783e738f1a597f9700f9ba4bc0d5de02278 (patch)
tree6809a8a325c4f0ef8158ed9d82df47ff53bdd294 /CMakeLists.txt
parent3c7f8a7013ef03df29045915eb6ea02a79812227 (diff)
Check for GeneratorRunner with cmake
Reviewed by Hugo Parente <hugo.lima@openbossa.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 92d52b724..319fd954d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,6 +4,7 @@ cmake_minimum_required(VERSION 2.6)
find_package(Qt4 4.5.0 REQUIRED)
find_package(ApiExtractor REQUIRED)
+find_package(GeneratorRunner REQUIRED)
add_definitions(${QT_DEFINITIONS})
@@ -27,6 +28,8 @@ shiboken.cpp
include_directories(${CMAKE_CURRENT_SOURCE_DIR}
${APIEXTRACTOR_INCLUDE_DIR}
${APIEXTRACTOR_INCLUDE_DIR}/..
+ ${GENERATORRUNNER_INCLUDE_DIR}
+ ${GENERATORRUNNER_INCLUDE_DIR}/..
${QT_INCLUDE_DIR}
${QT_QTCORE_INCLUDE_DIR})
@@ -34,6 +37,7 @@ add_library(shiboken_generator SHARED ${shiboken_SRC})
target_link_libraries(shiboken_generator
${APIEXTRACTOR_LIBRARY}
+ ${GENERATORRUNNER_LIBRARY}
${QT_QTCORE_LIBRARY}
${QT_QTXML_LIBRARY}
-lgenrunner) # FIXME libgenrunner needs a cmake FindPkg script!