aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHugo Lima <hugo.lima@openbossa.org>2009-11-11 17:22:56 -0200
committerMarcelo Lira <marcelo.lira@openbossa.org>2009-11-12 09:38:36 -0300
commitb58553f67867dc3e09243a137de560f83758f4a4 (patch)
treefbd8e7b9a1dfb0af95c55ec7af8af7da3982a7c0 /CMakeLists.txt
parent627d4cc994ba1c122995b367e2fc63a02d02d04a (diff)
Add visibility policies to libshiboken and for bindings generated by shiboken generator.
As shiboken generator needs minor changes to support inter-module dependencies, these changes about symbol visibility does not support inter-module dependencies, however support it is simple, because we just need to make some symbols visible to other DSO's. Reviewed by Marcelo Lira <marcelo.lira@openbossa.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d050dd408..50806e8ad 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,8 +9,10 @@ find_package(Boost COMPONENTS graph REQUIRED)
add_definitions(${QT_DEFINITIONS})
-set(CMAKE_CXX_FLAGS_RELEASE "-Wall -DNDEBUG -O2 -Wl,-O1 -Wl,--hash-style=gnu")
-set(CMAKE_CXX_FLAGS_DEBUG "-g -Wall")
+set(CMAKE_CXX_FLAGS_RELEASE "-Wall -DNDEBUG -O2 -Wl,-O1 -Wl,--hash-style=gnu -fvisibility=hidden")
+set(CMAKE_CXX_FLAGS_DEBUG "-g -Wall -fvisibility=hidden")
+# We need to define this when building shiboken, because windows need to known when to use dll_export or dll_import.
+add_definitions("-DLIBSHIBOKEN_BUILD")
set(LIB_SUFFIX "" CACHE STRING "Define suffix of directory name (32/64)" )
set(LIB_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}" CACHE PATH "The subdirectory relative to the install prefix where libraries will be installed (default is /lib${LIB_SUFFIX})" FORCE)