aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDidier Raboud <didier@odyx.homelinux.org>2010-03-04 16:25:14 +0100
committerAnderson Lizardo <anderson.lizardo@openbossa.org>2010-03-04 11:39:15 -0400
commitedc9cbfcfde439ccfe7100f53efc5d1e4ec34480 (patch)
tree94d0de805499abe6939d61572b7af78a458e2eff /CMakeLists.txt
parent36376eb1c97cad139b40197cefd6650e8afc49b2 (diff)
Link shiboken_generator against apiextractor
shiboken_generator uses several apiextractor symbols and classes, sot it must link against it. Reviewed-by: Anderson Lizardo <anderson.lizardo@openbossa.org> Reviewed-by: Marcelo Lira <marcelo.lira@openbossa.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1253f923e..600d21f2b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -56,6 +56,7 @@ include_directories(${CMAKE_CURRENT_SOURCE_DIR}
add_library(shiboken_generator SHARED ${shiboken_SRC})
target_link_libraries(shiboken_generator
+ ${APIEXTRACTOR_LIBRARY}
${GENERATORRUNNER_LIBRARY}
${QT_QTCORE_LIBRARY})