aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMarcelo Lira <marcelo.lira@openbossa.org>2011-01-10 20:20:11 -0300
committerMarcelo Lira <marcelo.lira@openbossa.org>2011-01-25 08:32:20 -0300
commita2318f763a91bc7c47bb751e39036ab95f4b45fc (patch)
tree444b617b85bc0ca356938ec06b73f95f78c57243 /CMakeLists.txt
parente674a8ddbc11e51f3f701e8ab7783aefec8cfeec (diff)
Added the "project-file" command line option.
The project file is a XML that provides the same options that could be provided via command line. Command line arguments added by further modules will be converted into xml tags on the project file following this rule: GENERATOR --new-boolean-option --new-option=SOMETHING in XML turns into: <new-boolean-option /> <new-option value="SOMETHING />
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5de216a8a..7a0d16074 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -59,7 +59,8 @@ include_directories(${CMAKE_CURRENT_SOURCE_DIR}
${CMAKE_CURRENT_BINARY_DIR}
${APIEXTRACTOR_INCLUDE_DIR}
${QT_INCLUDE_DIR}
- ${QT_QTCORE_INCLUDE_DIR})
+ ${QT_QTCORE_INCLUDE_DIR}
+ ${QT_QTXML_INCLUDE_DIR})
add_library(genrunner SHARED generator.cpp)
set_target_properties(genrunner PROPERTIES VERSION ${generator_VERSION} DEFINE_SYMBOL GENRUNNER_EXPORTS)
@@ -73,7 +74,8 @@ set_target_properties(generatorrunner PROPERTIES OUTPUT_NAME generatorrunner${ge
target_link_libraries(generatorrunner
genrunner
${APIEXTRACTOR_LIBRARY}
- ${QT_QTCORE_LIBRARY})
+ ${QT_QTCORE_LIBRARY}
+ ${QT_QTXML_LIBRARY})
# uninstall target
configure_file("${CMAKE_CURRENT_SOURCE_DIR}/cmake_uninstall.cmake"