aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLauro Neto <lauro.neto@openbossa.org>2009-09-02 18:55:17 -0300
committerLauro Neto <lauro.neto@openbossa.org>2009-09-02 19:06:42 -0300
commit25b08270fed65b2ef6e93fc2687c12c900e26309 (patch)
tree85d3bea2c16c114c1cbbb8827c1ae13b6d0bad99 /CMakeLists.txt
parent495f51aedd35a886b2ac04a6c54a78368cc28227 (diff)
Bump version to 0.3.1 (correct version)
The previous commit bumped to a wrong version. This also adds support to micro version numbers.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 804bdbf8b..67b20a1b2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,12 +11,13 @@ set(LIB_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}" CACHE PATH "The s
# lib generator version
set(generator_MAJOR_VERSION "0")
-set(generator_MINOR_VERSION "4")
-set(generator_VERSION "${generator_MAJOR_VERSION}.${generator_MINOR_VERSION}")
+set(generator_MINOR_VERSION "3")
+set(generator_MICRO_VERSION "1")
+set(generator_VERSION "${generator_MAJOR_VERSION}.${generator_MINOR_VERSION}.${generator_MICRO_VERSION}")
add_definitions(${QT_DEFINITIONS})
-set(boostpythongenerator_VERSION 0.4)
+set(boostpythongenerator_VERSION ${generator_VERSION})
configure_file(boostpythongeneratorversion.h.in ${CMAKE_CURRENT_BINARY_DIR}/boostpythongeneratorversion.h @ONLY)
set(CMAKE_BUILD_TYPE Debug)