aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHugo Lima <hugo.lima@openbossa.org>2009-11-20 19:00:30 -0200
committerMarcelo Lira <marcelo.lira@openbossa.org>2009-11-23 11:06:58 -0300
commit4908dc29a59be124ad01eadbfbbab2cdb66ed2f3 (patch)
treecf2ddbc9b11fdd80c298f11b80a879005f7cf013 /CMakeLists.txt
parent9ee8473f3ad9b19318110762e2a203996330d060 (diff)
- Fixes flags used with msvc.
- Set the library output path to the tests directory, so the unit tests can find the apiextractory library on windows. Reviewed by Marcelo Lira <marcelo.lira@openbossa.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8715e3a97..7274d9627 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,10 +9,11 @@ find_package(LibXml2 2.6.32 REQUIRED)
find_package(LibXslt 1.1.19 REQUIRED)
if (MSVC)
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} /O2 /GS- /GR- /DAPIEXTRACTOR_ENABLE_DUPLICATE_ENUM_VALUES /DAPIEXTRACTOR_BUILD")
+ set(CMAKE_CXX_FLAGS "/DWIN32 /D_WINDOWS /w /EHsc- /GS- /GR- /DAPIEXTRACTOR_ENABLE_DUPLICATE_ENUM_VALUES /DAPIEXTRACTOR_BUILD -D_SCL_SECURE_NO_WARNINGS")
else (MSVC)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -DAPIEXTRACTOR_ENABLE_DUPLICATE_ENUM_VALUES -fvisibility=hidden")
endif(MSVC)
+set(LIBRARY_OUTPUT_PATH ${CMAKE_BINARY_DIR}/tests)
set(apiextractor_MAJOR_VERSION 0)
set(apiextractor_MINOR_VERSION 3)
@@ -115,4 +116,3 @@ install(TARGETS apiextractor LIBRARY DESTINATION ${LIB_INSTALL_DIR}
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/apiextractor.pc DESTINATION ${LIB_INSTALL_DIR}/pkgconfig)
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/FindApiExtractor.cmake
DESTINATION share/cmake-2.6/Modules)
-