aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHugo Lima <hugo.lima@openbossa.org>2010-03-03 11:15:53 -0300
committerHugo Lima <hugo.lima@openbossa.org>2010-03-03 17:34:39 -0300
commit84b8b4a5b7581c4076bfbf1a19a324cb0561baae (patch)
tree5d698234fe4b9b99a0dfb1da75b6dae90650e0f0 /CMakeLists.txt
parent62dfdd85bbcac527be99183cfc8e8f7b92902f11 (diff)
Remove Boost::graph dependence from ApiExtractor by using our own code
for graph topological sort.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c46b7b261..0b6fcd8fb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,7 +2,6 @@ project(apiextractor)
cmake_minimum_required(VERSION 2.6)
-find_package(Boost COMPONENTS graph REQUIRED)
find_package(Qt4 4.5.0 REQUIRED)
find_package(LibXml2 2.6.32 REQUIRED)
@@ -37,6 +36,7 @@ docparser.cpp
doxygenparser.cpp
qtdocparser.cpp
fileout.cpp
+graph.cpp
reporthandler.cpp
typeparser.cpp
typesystem.cpp
@@ -71,7 +71,7 @@ include_directories(${CMAKE_CURRENT_SOURCE_DIR}
${CMAKE_CURRENT_BINARY_DIR}
${CMAKE_CURRENT_SOURCE_DIR}/parser
${CMAKE_CURRENT_SOURCE_DIR}/parser/rpp
- ${QT_INCLUDE_DIR} ${Boost_INCLUDE_DIR}
+ ${QT_INCLUDE_DIR}
${LIBXSLT_INCLUDE_DIR}
${LIBXML2_INCLUDE_DIR}
)
@@ -100,6 +100,7 @@ set(root_HEADERS
apiextractormacros.h
abstractmetalang.h
apiextractor.h
+graph.h
reporthandler.h
typesystem.h
fileout.h