aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHugo Lima <hugo.lima@openbossa.org>2009-08-20 13:48:45 -0300
committerHugo Lima <hugo.lima@openbossa.org>2009-08-20 13:48:45 -0300
commitdfa423ac3109e0e40cba5f43471b34b98ed3189d (patch)
treee900a9c1aeb99aa5a9cb2f90489c6629c81e6a57 /CMakeLists.txt
parent8f9ed5bd51827d96bda708121008b24bb3d55801 (diff)
Removed all generator stuff from APIExtractor, this stuff should be moved to the generator,
and the apiextractor library should be just what their name means, an API extractor. This break the APIExtractor source compatibility with no mercy!
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 2 insertions, 10 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8de46e16e..5072bf4d8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -31,7 +31,6 @@ docparser.cpp
doxygenparser.cpp
qtdocparser.cpp
fileout.cpp
-generator.cpp
reporthandler.cpp
typeparser.cpp
typesystem.cpp
@@ -59,13 +58,7 @@ parser/rpp/preprocessor.cpp
)
qt4_add_resources(apiextractor_RCCS_SRC generator.qrc)
-
-set(apiextractor_MOC_HEADERS
- fileout.h
- generator.h
-)
-
-qt4_wrap_cpp(apiextractor_MOC_SRC ${apiextractor_MOC_HEADERS})
+qt4_automoc(apiextractor_SRC)
include_directories(${CMAKE_CURRENT_SOURCE_DIR}
${CMAKE_CURRENT_BINARY_DIR}
@@ -76,7 +69,7 @@ include_directories(${CMAKE_CURRENT_SOURCE_DIR}
${LIBXML2_INCLUDE_DIRS}
)
-add_library(apiextractor SHARED ${apiextractor_SRC} ${apiextractor_MOC_SRC} ${apiextractor_RCCS_SRC})
+add_library(apiextractor SHARED ${apiextractor_SRC} ${apiextractor_RCCS_SRC})
target_link_libraries(apiextractor ${Boost_GRAPH_LIBRARY} ${LIBXSLT_LIBRARIES} ${LIBXML2_LIBRARIES} ${QT_QTCORE_LIBRARY} ${QT_QTXMLPATTERNS_LIBRARY} ${QT_QTXML_LIBRARY})
set_target_properties(apiextractor PROPERTIES SOVERSION ${apiextractor_VERSION})
@@ -103,7 +96,6 @@ add_custom_target(dist
set(root_HEADERS
abstractmetalang.h
-generator.h
apiextractor.h
reporthandler.h
typesystem.h