aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Tismer <tismer@stackless.com>2017-05-01 11:27:58 +0200
committerChristian Tismer <tismer@stackless.com>2017-05-09 08:34:27 +0000
commit98b6c69ee91a78d0eb7f20130272a612770fbbbe (patch)
treea2b29e40f4857d1f0da6cb657bf97b04aa621255 /CMakeLists.txt
parent81f92097fd8475bf8fb15cc8c249c4e71715e706 (diff)
Remove fixup_headers after fixing shiboken for C++11
The hack for VS 2015 is replaced by a shiboken patch. This must be immediately applied after shiboken was fixed. Reason: The build would work, but Windows will not load because of missing symbols! Task-number: PYSIDE-504 Change-Id: I3ce8989632748b8967228a9993b11c599a858b91 Reviewed-by: Friedemann Kleint <Friedemann.Kleint@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index af8b5fabb..4e9a89199 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -299,7 +299,14 @@ if (NOT SITE_PACKAGE)
endif()
endif()
-set(GENERATOR_EXTRA_FLAGS --generator-set=shiboken --enable-parent-ctor-heuristic --enable-pyside-extensions --enable-return-value-heuristic --use-isnull-as-nb_nonzero)
+set(GENERATOR_EXTRA_FLAGS --generator-set=shiboken
+ --enable-parent-ctor-heuristic
+ --enable-pyside-extensions
+ --enable-return-value-heuristic
+ --use-isnull-as-nb_nonzero)
+# 2017-04-24 The protected hack can unfortunately not be disabled, because
+# Clang does produce linker errors when we disable the hack.
+# But the ugly workaround in Python is replaced by a shiboken change.
if(WIN32 OR DEFINED AVOID_PROTECTED_HACK)
message(STATUS "PySide2 will be generated avoiding the protected hack!")
set(GENERATOR_EXTRA_FLAGS ${GENERATOR_EXTRA_FLAGS} --avoid-protected-hack)