aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLauro Neto <lauro.neto@openbossa.org>2009-09-03 10:38:55 -0300
committerLauro Neto <lauro.neto@openbossa.org>2009-09-03 10:41:28 -0300
commitb811be1ce4aa832ed7aa8542da535000924effa3 (patch)
treefa0853244e6129e38398e19dc7342df09e70513b /CMakeLists.txt
parent25b08270fed65b2ef6e93fc2687c12c900e26309 (diff)
Installs generator plugins in its own directory.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 67b20a1b2..828798062 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,10 +15,16 @@ set(generator_MINOR_VERSION "3")
set(generator_MICRO_VERSION "1")
set(generator_VERSION "${generator_MAJOR_VERSION}.${generator_MINOR_VERSION}.${generator_MICRO_VERSION}")
+set(generator_plugin_DIR ${LIB_INSTALL_DIR}/generatorrunner)
+
add_definitions(${QT_DEFINITIONS})
set(boostpythongenerator_VERSION ${generator_VERSION})
configure_file(boostpythongeneratorversion.h.in ${CMAKE_CURRENT_BINARY_DIR}/boostpythongeneratorversion.h @ONLY)
+
+# TODO Install it.
+configure_file(generator_plugin_dir.h.in ${CMAKE_CURRENT_BINARY_DIR}/generator_plugin_dir.h @ONLY)
+
set(CMAKE_BUILD_TYPE Debug)
include_directories(${CMAKE_CURRENT_SOURCE_DIR}