aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2021-09-27 18:32:37 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2022-02-04 15:50:53 +0100
commitb69d0262e0262274a8f050f9b627e9ca4a3b1833 (patch)
treef8fa43bdbf4144f571750e3daa0b9819292db03a /CMakeLists.txt
parent655d81386357e112cd0d29e86e9d4c22cb05f771 (diff)
CMake: Create new Shiboken6Tools CMake package
Create a new Shiboken6Tools CMake package which will contain information about the shiboken6 code generator executable. As a consequence, the existing Shiboken6 package will only contain info about the shiboken Python module and its helper shared library. The new Tools package will be searched for when cross-compiling both the shiboken and pyside projects. Adjust the pyside project to look for this new Tools package. Remove the 'data' custom target, it serves no purpose. One consequence is that the shiboken pkg-config .pc file will not contain a path to the code generator executable anymore. Currently, no new .pc file is created for the newly split package. As a drive-by, adjust the Shiboken6 find_package calls to look for version 6 rather than 2. Task-number: PYSIDE-802 Task-number: PYSIDE-1033 Change-Id: I0df29801b1f59010df8f13ac0c9f2d368fa4d1cb Reviewed-by: Friedemann Kleint <Friedemann.Kleint@qt.io> Reviewed-by: Cristian Maureira-Fredes <cristian.maureira-fredes@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 65172b351..e17f259b1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,11 +14,12 @@ set(is_pyside6_superproject_build 1)
add_subdirectory(sources/shiboken6)
-# Semi-hack to include exported shiboken variables.
+# Ensure Shiboken6 and Shiboken6Tools packags are found during super-build
list(APPEND CMAKE_PREFIX_PATH "${CMAKE_CURRENT_BINARY_DIR}/sources/shiboken6/data")
+list(APPEND CMAKE_PREFIX_PATH "${CMAKE_CURRENT_BINARY_DIR}/sources/shiboken6/generator")
add_subdirectory(sources/pyside6)
add_subdirectory(sources/pyside-tools)
-# Semi-hack to include exported pyside6 variables.
+# Ensure PySide package is found during super-build
list(APPEND CMAKE_PREFIX_PATH "${CMAKE_CURRENT_BINARY_DIR}/sources/pyside6/libpyside")