aboutsummaryrefslogtreecommitdiffstats
path: root/PySide/CMakeLists.txt
diff options
context:
space:
mode:
authorCarlos Goncalves <mail@cgoncalves.info>2010-09-14 11:41:41 -0300
committerrenatofilho <renato.filho@openbossa.org>2010-09-14 11:42:52 -0300
commit149646c766fd46f7f59922436c0323fd6a2d78a4 (patch)
tree7bc2b9744217955aff3131a2403a9b26f2170571 /PySide/CMakeLists.txt
parentb315368a1b8bd1af8fadca38d0356c85662ea3a7 (diff)
parent6fc086e9f9a786521492593b92889c735697191e (diff)
Treat modules as library targets.
This fixes dynamic linking on Mac OS X. Previously modules were been linked to libpyside in the build tree even when installed (ie. hardcoded). Reviewer: Hugo Parente Lima <hugo.pl@gmail.com> Luciano Wolf <luciano.wolf@openbossa.org>
Diffstat (limited to 'PySide/CMakeLists.txt')
-rw-r--r--PySide/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/PySide/CMakeLists.txt b/PySide/CMakeLists.txt
index 3114991df..8769d3a63 100644
--- a/PySide/CMakeLists.txt
+++ b/PySide/CMakeLists.txt
@@ -39,8 +39,7 @@ macro(create_pyside_module module_name module_include_dir module_libraries modul
# install
- install(FILES ${pyside_BINARY_DIR}/${module_name}${CMAKE_DEBUG_POSTFIX}${${module_name}_suffix}
- DESTINATION ${SITE_PACKAGE}/PySide${pyside_SUFFIX})
+ install(TARGETS ${module_name} LIBRARY DESTINATION ${SITE_PACKAGE}/PySide)
string(TOLOWER ${module_name} lower_module_name)
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/PySide/${module_name}/pyside_${lower_module_name}_python.h
DESTINATION include/PySide${pyside_SUFFIX}/${module_name}/)