aboutsummaryrefslogtreecommitdiffstats
path: root/PySide/CMakeLists.txt
diff options
context:
space:
mode:
authorRenato Filho <renato.filho@openbossa.org>2010-05-19 14:20:18 -0300
committerRenato Filho <renato.filho@openbossa.org>2010-05-19 17:39:56 -0300
commitb830e6696627e1c740e7f93f7978c604a59ee7ac (patch)
tree7d375d14693b6d5b1530d6de9e4fbbc31ef4526f /PySide/CMakeLists.txt
parent101a3f0e33a747e0627acb2429c01acac9a88798 (diff)
Implemented SO detection support.
Reviewer: Hugo Parente Lima <hugo.lima@openbossa.org>, Luciano Wolf <luciano.wolf@openbossa.org>
Diffstat (limited to 'PySide/CMakeLists.txt')
-rw-r--r--PySide/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/PySide/CMakeLists.txt b/PySide/CMakeLists.txt
index 210c595f4..24b6d16db 100644
--- a/PySide/CMakeLists.txt
+++ b/PySide/CMakeLists.txt
@@ -5,7 +5,7 @@ install(FILES "${CMAKE_CURRENT_SOURCE_DIR}/__init__.py"
macro(execute_generator module sources typesystem_path)
add_custom_command(OUTPUT ${${sources}}
COMMAND ${GENERATOR} ${GENERATOR_EXTRA_FLAGS}
- ${pyside_SOURCE_DIR}/global.h
+ ${CMAKE_BINARY_DIR}/PySide/global.h
--include-paths=${pyside_SOURCE_DIR}:${QT_INCLUDE_DIR}
--typesystem-paths=${pyside_SOURCE_DIR}:${typesystem_path}
--output-directory=${CMAKE_CURRENT_BINARY_DIR}
@@ -16,6 +16,11 @@ COMMENT "Running generator for ${module}..."
)
endmacro(execute_generator)
+# Configure include based on platform
+configure_file("${CMAKE_CURRENT_SOURCE_DIR}/global.h.in"
+ "${CMAKE_CURRENT_BINARY_DIR}/global.h" @ONLY)
+
+
# Only add subdirectory if the associated Qt module is found.
macro(HAS_QT_MODULE var name)
if (DISABLE_${name})