aboutsummaryrefslogtreecommitdiffstats
path: root/PySide/CMakeLists.txt
diff options
context:
space:
mode:
authorHugo Lima <hugo.lima@openbossa.org>2010-01-11 19:19:50 -0200
committerHugo Lima <hugo.lima@openbossa.org>2010-01-27 16:55:04 -0200
commited108a7f00566aee69ea4dfed4eb94f5fe37ed1f (patch)
tree37be84998ae41a982f06274f195f6ab589d7d8a9 /PySide/CMakeLists.txt
parent95959b4c80e30df8fd6332b883cff6221d6b9c63 (diff)
Add typesystem path variable to execute_generator CMake macro.
Diffstat (limited to 'PySide/CMakeLists.txt')
-rw-r--r--PySide/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/PySide/CMakeLists.txt b/PySide/CMakeLists.txt
index 7255ccead..ecb193dc4 100644
--- a/PySide/CMakeLists.txt
+++ b/PySide/CMakeLists.txt
@@ -2,12 +2,12 @@ project(pyside)
install(FILES "${CMAKE_CURRENT_SOURCE_DIR}/__init__.py"
DESTINATION "${SITE_PACKAGE}/${BINDING_NAME}")
-macro(execute_generator module sources)
+macro(execute_generator module sources typesystem_path)
add_custom_command(OUTPUT ${${sources}}
COMMAND ${GENERATOR} ${GENERATOR_EXTRA_FLAGS}
${CMAKE_CURRENT_SOURCE_DIR}/../global.h
--include-paths=${QT_INCLUDE_DIR}
- --typesystem-paths=${pyside_SOURCE_DIR}
+ --typesystem-paths=${pyside_SOURCE_DIR}:${typesystem_path}
--output-directory=${CMAKE_CURRENT_BINARY_DIR}
--license-file=${CMAKE_CURRENT_SOURCE_DIR}/../licensecomment.txt
${CMAKE_CURRENT_SOURCE_DIR}/typesystem_${module}.xml