aboutsummaryrefslogtreecommitdiffstats
path: root/PySide/CMakeLists.txt
diff options
context:
space:
mode:
authorRenato Filho <renato.filho@openbossa.org>2010-09-08 19:32:33 -0300
committerRenato Filho <renato.filho@openbossa.org>2010-09-08 19:39:31 -0300
commit63cacc4411cd52e359e1867532524ee816248b61 (patch)
tree99d52fcf0992c694299d9b9e9347c06b5e34c041 /PySide/CMakeLists.txt
parent6daa2edea54d10e761d0432137373f226f2613ca (diff)
Created module shutdown function necessary to avoid call python functions before module exit.
Reviewer: Luciano Wolf <luciano.wolf@openbossa.org> Hugo Parente Lima <hugo.pl@gmail.com>
Diffstat (limited to 'PySide/CMakeLists.txt')
-rw-r--r--PySide/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/PySide/CMakeLists.txt b/PySide/CMakeLists.txt
index e4b6a1d8c..66621befe 100644
--- a/PySide/CMakeLists.txt
+++ b/PySide/CMakeLists.txt
@@ -1,5 +1,5 @@
project(pyside)
-install(FILES "${CMAKE_CURRENT_SOURCE_DIR}/__init__.py"
+install(FILES "${CMAKE_CURRENT_SOURCE_DIR}/__init__.py" "${CMAKE_CURRENT_SOURCE_DIR}/private.py"
DESTINATION "${SITE_PACKAGE}/${BINDING_NAME}")
macro(execute_generator module sources typesystem_path)
@@ -106,6 +106,10 @@ endmacro()
execute_process(COMMAND ${CMAKE_COMMAND} -E copy_if_different "${CMAKE_CURRENT_SOURCE_DIR}/__init__.py"
"${CMAKE_BINARY_DIR}/PySide/__init__.py")
+
+execute_process(COMMAND ${CMAKE_COMMAND} -E copy_if_different "${CMAKE_CURRENT_SOURCE_DIR}/private.py"
+ "${CMAKE_BINARY_DIR}/PySide/private.py")
+#
# Try to find QtMultimedia
# TODO: Remove this hack when cmake support QtMultimedia module
if (NOT QT_QTMULTIMEDIA_FOUND AND ${QTVERSION} VERSION_GREATER 4.5.9)