aboutsummaryrefslogtreecommitdiffstats
path: root/PySide/CMakeLists.txt
diff options
context:
space:
mode:
authorCarlos Goncalves <mail@cgoncalves.info>2010-09-04 02:10:33 +0100
committerCarlos Goncalves <mail@cgoncalves.info>2010-09-04 02:33:08 +0100
commit6fc086e9f9a786521492593b92889c735697191e (patch)
tree79aa96ffcc6032d2f21c65d3ed906b365d037c8c /PySide/CMakeLists.txt
parent823eec81c245f56cd2baf7c9fe0b1bf006500561 (diff)
Treat modules as library targets.
This fixes dynamic linking on Mac OS X. Previously modules were been linked to libpyside in the build tree even when installed (ie. hardcoded).
Diffstat (limited to 'PySide/CMakeLists.txt')
-rw-r--r--PySide/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/PySide/CMakeLists.txt b/PySide/CMakeLists.txt
index e4b6a1d8c..522d1eca7 100644
--- a/PySide/CMakeLists.txt
+++ b/PySide/CMakeLists.txt
@@ -43,8 +43,7 @@ macro(create_pyside_module module_name module_include_dir module_libraries modul
# install
- install(FILES ${pyside_BINARY_DIR}/${module_name}${CMAKE_DEBUG_POSTFIX}${${module_name}_suffix}
- DESTINATION ${SITE_PACKAGE}/PySide)
+ install(TARGETS ${module_name} LIBRARY DESTINATION ${SITE_PACKAGE}/PySide)
string(TOLOWER ${module_name} lower_module_name)
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/PySide/${module_name}/pyside_${lower_module_name}_python.h
DESTINATION include/PySide/${module_name}/)