aboutsummaryrefslogtreecommitdiffstats
path: root/PySide/CMakeLists.txt
diff options
context:
space:
mode:
authorHugo Lima <hugo.lima@openbossa.org>2009-09-09 13:36:26 -0300
committerHugo Lima <hugo.lima@openbossa.org>2009-09-09 13:36:26 -0300
commit0d4c968a6c323eda43af21b34350995e793ff2d5 (patch)
treeac01a42b0c455ea5d8595a096adc9a3145638ed4 /PySide/CMakeLists.txt
Initial experiments with shiboken and Qt
Diffstat (limited to 'PySide/CMakeLists.txt')
-rw-r--r--PySide/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/PySide/CMakeLists.txt b/PySide/CMakeLists.txt
new file mode 100644
index 000000000..aa4b114d6
--- /dev/null
+++ b/PySide/CMakeLists.txt
@@ -0,0 +1,15 @@
+macro(execute_generator module sources)
+add_custom_command(OUTPUT ${${sources}}
+COMMAND ${GENERATOR} ${GENERATOR_EXTRA_FLAGS}
+ ${CMAKE_CURRENT_SOURCE_DIR}/../global.h
+ --include-paths=${QT_INCLUDE_DIR}
+ --typesystem-paths=${typesystem_SOURCE_DIR}
+ --output-directory=${CMAKE_CURRENT_BINARY_DIR}
+ --license-file=${CMAKE_CURRENT_SOURCE_DIR}/../licensecomment.txt
+ ${CMAKE_CURRENT_SOURCE_DIR}/typesystem_${module}.xml
+WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
+COMMENT "Running generator for ${module}..."
+)
+endmacro(execute_generator)
+
+add_subdirectory(QtCore)