aboutsummaryrefslogtreecommitdiffstats
path: root/PySide/CMakeLists.txt
diff options
context:
space:
mode:
authorMarcelo Lira <marcelo.lira@openbossa.org>2010-06-21 15:21:25 -0300
committerMarcelo Lira <marcelo.lira@openbossa.org>2010-06-21 16:10:40 -0300
commite323cd90f7922ffa8d0121b87c3a00c6706e0dd0 (patch)
tree921d3a0434df77d4340cdfb8f87f098ceb56c47c /PySide/CMakeLists.txt
parent143946435835163d750b08982a906834a575fa64 (diff)
PySide now installs its type system files.
The pyside.pc file now has a "typesystemdir" variable pointing to the directory where the type system files are installed. Example usage: pkg-config pyside --variable=typesystemdir Also set the "PYSIDE_TYPESYSTEMS" CMake variable on libpyside/PySideConfig.cmake.in to point to the same path of pkg-config's "typesystemdir". Reviewed by Hugo Parente <hugo.lima@openbossa.org> Reviewed by Luciano Wolf <luciano.wolf@openbossa.org>
Diffstat (limited to 'PySide/CMakeLists.txt')
-rw-r--r--PySide/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/PySide/CMakeLists.txt b/PySide/CMakeLists.txt
index 3162cbb17..b1b328641 100644
--- a/PySide/CMakeLists.txt
+++ b/PySide/CMakeLists.txt
@@ -97,3 +97,8 @@ HAS_QT_MODULE(QT_QTSCRIPTTOOLS_FOUND QtScriptTools)
HAS_QT_MODULE(QT_QTMULTIMEDIA_FOUND QtMultimedia)
HAS_QT_MODULE(QT_PHONON_FOUND phonon)
HAS_QT_MODULE(QT_QTDECLARATIVE_FOUND QtDeclarative)
+
+# install
+install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/typesystem_templates.xml
+ DESTINATION share/PySide/typesystems)
+