aboutsummaryrefslogtreecommitdiffstats
path: root/PySide/QtCore/CMakeLists.txt
diff options
context:
space:
mode:
authorAnderson Lizardo <anderson.lizardo@openbossa.org>2010-08-16 21:59:45 -0400
committerAnderson Lizardo <anderson.lizardo@openbossa.org>2010-08-26 11:06:55 -0400
commitd53f699751047b18e7c729de3cdcc7eb45b32dd1 (patch)
treecf5e0174ecfda9d08f3dd37d726a3c1834683cc4 /PySide/QtCore/CMakeLists.txt
parent3c36d444729ee9285bb4ab0252968057bf904a8d (diff)
Simplify handling of typesystems for multiple OSes
* Factor out install() commands into PySide/CMakeLists.txt * Drop typesystem_<module>_common.xml and typesystem_<module>.xml.in, and make typesystem_<module>_<os>.xml (if exists) include typesystem_<module>.xml (which holds common data) Reviewed-by: Luciano Wolf <luciano.wolf@openbossa.org> Reviewed-by: Hugo Parente Lima <hugo.lima@openbossa.org>
Diffstat (limited to 'PySide/QtCore/CMakeLists.txt')
-rw-r--r--PySide/QtCore/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/PySide/QtCore/CMakeLists.txt b/PySide/QtCore/CMakeLists.txt
index b6c753416..5a5951ba9 100644
--- a/PySide/QtCore/CMakeLists.txt
+++ b/PySide/QtCore/CMakeLists.txt
@@ -134,7 +134,7 @@ ${QtCore_46_SRC}
${QtCore_47_SRC}
)
-set(QtCore_typesystem_path ${CMAKE_CURRENT_BINARY_DIR})
+set(QtCore_typesystem_path "")
set(QtCore_include_dirs ${CMAKE_CURRENT_SOURCE_DIR}
${CMAKE_CURRENT_BINARY_DIR}/${BINDING_NAME}/QtCore/
${QT_INCLUDE_DIR}
@@ -147,7 +147,6 @@ set(QtCore_libraries pyside
${QT_QTCORE_LIBRARY})
create_pyside_module(QtCore
- ${CMAKE_CURRENT_SOURCE_DIR}/typesystem_core.xml
QtCore_include_dirs
QtCore_libraries
""