aboutsummaryrefslogtreecommitdiffstats
path: root/PySide/QtCore/CMakeLists.txt
diff options
context:
space:
mode:
authorRenato Filho <renato.filho@openbossa.org>2011-06-07 11:07:06 -0300
committerHugo Parente Lima <hugo.pl@gmail.com>2012-03-08 16:54:28 -0300
commit23d1e497d87ee9ba4b6aff96f65e67e91cc73705 (patch)
treec6ca9c7ba871ac0e0fc72900f17d11526120a8f5 /PySide/QtCore/CMakeLists.txt
parent3e88ef1c54f54e9aca8c82b2519a4525a11c1fc1 (diff)
Implemented support to MSG type on windows.
Diffstat (limited to 'PySide/QtCore/CMakeLists.txt')
-rw-r--r--PySide/QtCore/CMakeLists.txt15
1 files changed, 14 insertions, 1 deletions
diff --git a/PySide/QtCore/CMakeLists.txt b/PySide/QtCore/CMakeLists.txt
index df05bf652..86df1d172 100644
--- a/PySide/QtCore/CMakeLists.txt
+++ b/PySide/QtCore/CMakeLists.txt
@@ -36,6 +36,17 @@ else()
)
endif()
+if(ENABLE_WIN)
+ set(QtCore_typesystem "typesystem_core_win.xml")
+ set(QtCore_extra_SRC
+ ${CMAKE_CURRENT_BINARY_DIR}/PySide/QtCore/msg_wrapper.cpp
+ ${CMAKE_CURRENT_BINARY_DIR}/PySide/QtCore/point_wrapper.cpp
+ )
+else()
+ set(QtCore_typesystem "typesystem_core.xml")
+ set(QtCore_extra_SRC "")
+endif()
+
set(QtCore_SRC
${CMAKE_CURRENT_BINARY_DIR}/PySide/QtCore/qabstracteventdispatcher_wrapper.cpp
${CMAKE_CURRENT_BINARY_DIR}/PySide/QtCore/qabstractfileengine_wrapper.cpp
@@ -135,6 +146,7 @@ ${CMAKE_CURRENT_BINARY_DIR}/PySide/QtCore/qxmlstreamreader_wrapper.cpp
${CMAKE_CURRENT_BINARY_DIR}/PySide/QtCore/qxmlstreamwriter_wrapper.cpp
${QtCore_46_SRC}
${QtCore_47_SRC}
+${QtCore_extra_SRC}
)
set(QtCore_typesystem_path "")
@@ -155,4 +167,5 @@ create_pyside_module(QtCore
""
QtCore_typesystem_path
QtCore_SRC
- QtCore_gluecode)
+ QtCore_gluecode
+ ${CMAKE_CURRENT_SOURCE_DIR}/${QtCore_typesystem})