aboutsummaryrefslogtreecommitdiffstats
path: root/PySide/QtGui/CMakeLists.txt
diff options
context:
space:
mode:
authorHugo Lima <hugo.lima@openbossa.org>2010-02-18 17:49:33 -0200
committerHugo Lima <hugo.lima@openbossa.org>2010-02-18 18:00:49 -0200
commitda44aaaef1f8206348177b90542aec8466e26b2a (patch)
tree6ad908ad8139326f5a4edef7ded3ba2ad5ff49ad /PySide/QtGui/CMakeLists.txt
parent3599b75f885983aa87e8ef8baf0fb2c65ef175cb (diff)
Do not link a python module to other python module.
Diffstat (limited to 'PySide/QtGui/CMakeLists.txt')
-rw-r--r--PySide/QtGui/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/PySide/QtGui/CMakeLists.txt b/PySide/QtGui/CMakeLists.txt
index 8a589d90f..d22d28fcd 100644
--- a/PySide/QtGui/CMakeLists.txt
+++ b/PySide/QtGui/CMakeLists.txt
@@ -462,11 +462,10 @@ include_directories(${CMAKE_CURRENT_SOURCE_DIR}
${PYTHON_INCLUDE_PATH}
${QtCore_BINARY_DIR}/PySide/QtCore/
)
-add_library(QtGui SHARED ${QtGui_SRC})
+add_library(QtGui MODULE ${QtGui_SRC})
set_property(TARGET QtGui PROPERTY PREFIX "")
target_link_libraries(QtGui
pyside
- QtCore
${PYTHON_LIBRARIES}
${SHIBOKEN_LIBRARY}
${QT_QTGUI_LIBRARY}