aboutsummaryrefslogtreecommitdiffstats
path: root/PySide/QtMultimedia/CMakeLists.txt
diff options
context:
space:
mode:
authorAnderson Lizardo <anderson.lizardo@openbossa.org>2010-08-16 21:59:45 -0400
committerAnderson Lizardo <anderson.lizardo@openbossa.org>2010-08-26 11:06:55 -0400
commitd53f699751047b18e7c729de3cdcc7eb45b32dd1 (patch)
treecf5e0174ecfda9d08f3dd37d726a3c1834683cc4 /PySide/QtMultimedia/CMakeLists.txt
parent3c36d444729ee9285bb4ab0252968057bf904a8d (diff)
Simplify handling of typesystems for multiple OSes
* Factor out install() commands into PySide/CMakeLists.txt * Drop typesystem_<module>_common.xml and typesystem_<module>.xml.in, and make typesystem_<module>_<os>.xml (if exists) include typesystem_<module>.xml (which holds common data) Reviewed-by: Luciano Wolf <luciano.wolf@openbossa.org> Reviewed-by: Hugo Parente Lima <hugo.lima@openbossa.org>
Diffstat (limited to 'PySide/QtMultimedia/CMakeLists.txt')
-rw-r--r--PySide/QtMultimedia/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/PySide/QtMultimedia/CMakeLists.txt b/PySide/QtMultimedia/CMakeLists.txt
index 1829697ec..3dd7abbf4 100644
--- a/PySide/QtMultimedia/CMakeLists.txt
+++ b/PySide/QtMultimedia/CMakeLists.txt
@@ -17,7 +17,7 @@ set(QtMultimedia_SRC
${CMAKE_CURRENT_BINARY_DIR}/PySide/QtMultimedia/qvideoframe_wrapper.cpp
${CMAKE_CURRENT_BINARY_DIR}/PySide/QtMultimedia/qtmultimedia_module_wrapper.cpp
)
-set(QtMultimedia_typesystem_path "${CMAKE_CURRENT_BINARY_DIR}:${QtCore_SOURCE_DIR}:${QtGui_SOURCE_DIR}:${QtGui_BINARY_DIR}")
+set(QtMultimedia_typesystem_path "${QtCore_SOURCE_DIR}:${QtGui_SOURCE_DIR}")
set(QtMultimedia_include_dirs ${CMAKE_CURRENT_SOURCE_DIR}
${CMAKE_CURRENT_BINARY_DIR}/PySide/QtMultimedia/
@@ -40,7 +40,6 @@ set(QtMultimedia_libraries pyside
set(QtMultimedia_deps QtGui)
create_pyside_module(QtMultimedia
- ${CMAKE_CURRENT_SOURCE_DIR}/typesystem_multimedia.xml
QtMultimedia_include_dirs
QtMultimedia_libraries
QtMultimedia_deps