aboutsummaryrefslogtreecommitdiffstats
path: root/PySide/QtUiTools/CMakeLists.txt
diff options
context:
space:
mode:
authorrenatofilho <renato.filho@openbossa.org>2010-10-06 18:55:42 -0300
committerrenatofilho <renato.filho@openbossa.org>2010-10-07 12:18:31 -0300
commit24cbdd8dfa3cd01184d0dae297c15547d4962293 (patch)
treea1afafc9b9dc216e6e62a4529a4cf0c1fa5cc71d /PySide/QtUiTools/CMakeLists.txt
parent83533ddc5d89feb046863b4dacc86be3967e4a6b (diff)
Created uiloader plugin used to register new types before QUiLoader.
This is used to register a new python type which can be used in ui description files. Reviewer: Hugo Parente Lima <hugo.pl@gmail.com> Luciano Wolf <luciano.wolf@openbossa.org>
Diffstat (limited to 'PySide/QtUiTools/CMakeLists.txt')
-rw-r--r--PySide/QtUiTools/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/PySide/QtUiTools/CMakeLists.txt b/PySide/QtUiTools/CMakeLists.txt
index 9922e9d10..4054ffc9b 100644
--- a/PySide/QtUiTools/CMakeLists.txt
+++ b/PySide/QtUiTools/CMakeLists.txt
@@ -10,18 +10,22 @@ set(QtUiTools_include_dirs ${CMAKE_CURRENT_SOURCE_DIR}
${QT_QTCORE_INCLUDE_DIR}
${QT_QTGUI_INCLUDE_DIR}
${QT_QTXML_INCLUDE_DIR}
+ ${QT_QTDESIGNER_INCLUDE_DIR}
${QT_QTUITOOLS_INCLUDE_DIR}
${PYTHON_INCLUDE_PATH}
${SHIBOKEN_INCLUDE_DIR}
${libpyside_SOURCE_DIR}
+ ${plugins_SOURCE_DIR}
${QtCore_BINARY_DIR}/PySide/QtCore/
${QtXml_BINARY_DIR}/PySide/QtXml/
${QtGui_BINARY_DIR}/PySide/QtGui/
${CMAKE_CURRENT_BINARY_DIR}/PySide/QtUiTools)
set(QtUiTools_libraries pyside
+ uiplugin
${PYSIDE_PYTHON_LIBRARIES}
${QT_QTCORE_LIBRARY}
${QT_QTGUI_LIBRARY}
+ ${QT_QTDESIGNER_LIBRARY}
${QT_QTUITOOLS_LIBRARY})
set(QtUiTools_deps QtGui QtXml)
create_pyside_module(QtUiTools
@@ -31,3 +35,4 @@ create_pyside_module(QtUiTools
QtUiTools_typesystem_path
QtUiTools_SRC
"")
+