aboutsummaryrefslogtreecommitdiffstats
path: root/PySide2/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Tismer <tismer@stackless.com>2016-10-18 18:10:08 +0200
committerChristian Tismer <tismer@stackless.com>2016-10-19 08:26:36 +0000
commitdc22a4e370cedc23371029543a919dec2b02a23d (patch)
treee16b0c82a92488cc5e9ad59f5b22484a85285d60 /PySide2/CMakeLists.txt
parentc3d0ece2e4fff0c540201e9d803010d7b9a32a83 (diff)
Build QtOpenGL support
I had to correct the inheritance - QtOpenGL is dependent of QtWidgets. QtGui is not sufficient. Enabled the QtOpenGL tests as well. We also prepared the transition from Qt5WebKit to Qt5WebEngine, because since Qt 5.6 Qt5WebKit is removed and the tests are never enabled. Task-number: PYSIDE-314 Task-number: PYSIDE-320 Change-Id: I9b6c0a92470b5a8c1cdaf2723f918bf4dcd715c0 Reviewed-by: Friedemann Kleint <Friedemann.Kleint@qt.io>
Diffstat (limited to 'PySide2/CMakeLists.txt')
-rw-r--r--PySide2/CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/PySide2/CMakeLists.txt b/PySide2/CMakeLists.txt
index 38219467e..8bf5e53cd 100644
--- a/PySide2/CMakeLists.txt
+++ b/PySide2/CMakeLists.txt
@@ -161,6 +161,11 @@ else()
ENDIF()
HAS_QT_MODULE(Qt5Gui_FOUND QtGui)
HAS_QT_MODULE(Qt5Widgets_FOUND QtWidgets)
+# This module is deprecated and should be replaces by QtGui.
+# See http://doc.qt.io/qt-5/qtgui-index.html
+# Update: We support QtOpenGL now!
+# Note: The dependency is wrong: QtWidgets is needed!
+HAS_QT_MODULE(Qt5OpenGL_FOUND QtOpenGL)
HAS_QT_MODULE(Qt5PrintSupport_FOUND QtPrintSupport)
HAS_QT_MODULE(Qt5Svg_FOUND QtSvg)
HAS_QT_MODULE(Qt5Sql_FOUND QtSql)
@@ -175,12 +180,6 @@ if(NOT MSVC)
else()
set(DISABLE_QtWebKitWidgets 1 PARENT_SCOPE)
ENDIF()
-###
-# This module is deprecated! It should be replaces by QtGui.
-# We keep the source code until we are done with QtGui migration.
-# See http://doc.qt.io/qt-5/qtgui-index.html
-# HAS_QT_MODULE(Qt5OpenGL_FOUND QtOpenGL)
-###
if(Qt5Designer_FOUND)
HAS_QT_MODULE(Qt5UiTools_FOUND QtUiTools)