aboutsummaryrefslogtreecommitdiffstats
path: root/data/CMakeLists.txt
diff options
context:
space:
mode:
authorrenatofilho <renato.filho@openbossa.org>2010-09-20 18:58:14 -0300
committerHugo Parente Lima <hugo.pl@gmail.com>2012-03-08 16:07:16 -0300
commit602bbf5a86c1c5c9c84535539b4ef617c120c3af (patch)
treec5b82d1a000ea2f503b6078864d29d3421cb9e35 /data/CMakeLists.txt
parent7f5723eac1366e901391fb5771f4a70a45dc6932 (diff)
Use CMAKE_<CONFIG>_POSTFIX on config files, used for cmake and pkgconfig.
Fixes bug #286. Reviewer: Hugo Parente Lima <hugo.pl@gmail.com> Luciano Wolf <luciano.wolf@openbossa.org>
Diffstat (limited to 'data/CMakeLists.txt')
-rw-r--r--data/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/data/CMakeLists.txt b/data/CMakeLists.txt
index 85c9d6a99..9ad9381dd 100644
--- a/data/CMakeLists.txt
+++ b/data/CMakeLists.txt
@@ -1,3 +1,9 @@
+if (CMAKE_BUILD_TYPE STREQUAL "Debug")
+ set(LIBRARY_OUTPUT_SUFFIX ${CMAKE_DEBUG_POSTFIX})
+else()
+ set(LIBRARY_OUTPUT_SUFFIX ${CMAKE_RELEASE_POSTFIX})
+endif()
+
configure_file("${CMAKE_CURRENT_SOURCE_DIR}/ShibokenConfig.cmake.in"
"${CMAKE_CURRENT_BINARY_DIR}/ShibokenConfig.cmake" @ONLY)
configure_file("${CMAKE_CURRENT_SOURCE_DIR}/ShibokenConfigVersion.cmake.in"