aboutsummaryrefslogtreecommitdiffstats
path: root/doc/CMakeLists.txt
diff options
context:
space:
mode:
authorLuciano Wolf <luciano.wolf@openbossa.org>2010-06-01 13:59:07 -0300
committerLuciano Wolf <luciano.wolf@openbossa.org>2010-06-01 17:33:19 -0300
commit02f4a14bab2d2056097bb9f05ebbd7cb91da22d1 (patch)
tree489f4cf04e2047375dfc74e9ebf497a7f37542a0 /doc/CMakeLists.txt
parent3e7a66f0fcdfdadb98b120d239378a60bf1bed1c (diff)
Updating documentation to include QtDeclarative and support new features.
Reviewer: Hugo Parente Lima <hugo.lima@openbossa.org>, Renato Araújo <renato.filho@openbossa.org>
Diffstat (limited to 'doc/CMakeLists.txt')
-rw-r--r--doc/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
index faab17634..7bad422df 100644
--- a/doc/CMakeLists.txt
+++ b/doc/CMakeLists.txt
@@ -28,7 +28,7 @@ string(REGEX REPLACE "^Qt" "" module_name ${module})
string(TOLOWER ${module_name} module_name)
add_custom_target("${module}-apidoc"
COMMAND ${GENERATOR} --generatorSet=qtdoc
- ${pyside_SOURCE_DIR}/global.h
+ ${pyside_BINARY_DIR}/global.h
--include-paths=${QT_INCLUDE_DIR}:${QT_QTCORE_INCLUDE_DIR}
--typesystem-paths=${pyside_SOURCE_DIR}:${${module}_BINARY_DIR}:${typesystem_path}
${pyside_SOURCE_DIR}/${module}/typesystem_${module_name}.xml
@@ -61,6 +61,7 @@ create_doc(QtScriptTools "${QtCore_SOURCE_DIR}:${QtScript_SOURCE_DIR}:${QtGui_SO
create_doc(QtTest "${QtCore_SOURCE_DIR}:${QtGui_SOURCE_DIR}:${QtGui_BINARY_DIR}")
create_doc(QtXmlPatterns "${QtCore_SOURCE_DIR}")
create_doc(phonon "${QtCore_SOURCE_DIR}:${QtGui_SOURCE_DIR}:${QtGui_BINARY_DIR}")
+create_doc(QtDeclarative "${QtCore_SOURCE_DIR}:${QtGui_SOURCE_DIR}:${QtGui_BINARY_DIR}:${QtNetwork_SOURCE_DIR}")
#create devhelp file
add_custom_target(apidevhelp