aboutsummaryrefslogtreecommitdiffstats
path: root/doc/CMakeLists.txt
diff options
context:
space:
mode:
authorHugo Parente Lima <hugo.pl@gmail.com>2010-09-15 17:24:57 -0300
committerHugo Parente Lima <hugo.pl@gmail.com>2010-09-15 18:17:37 -0300
commit9c1186eacda68f9573d228291aecd022a9493c10 (patch)
treeb29b58cccf29c65e372a61e8febdc83aacbdcc45 /doc/CMakeLists.txt
parent7ecf20e2a7389bf4f11f0c229338606fd001e75d (diff)
Add "doc" target to be able to build the docs out of the source directory.
Diffstat (limited to 'doc/CMakeLists.txt')
-rw-r--r--doc/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
new file mode 100644
index 000000000..d78844dc8
--- /dev/null
+++ b/doc/CMakeLists.txt
@@ -0,0 +1,10 @@
+
+find_program(SPHINX sphinx-build DOC "Path to sphinx-build binary.")
+
+if (SPHINX)
+ message("-- sphinx-build - found")
+ configure_file(conf.py.in conf.py @ONLY)
+ add_custom_target(doc ${SPHINX} -b html -c . ${CMAKE_CURRENT_SOURCE_DIR} html )
+else()
+ message("-- sphinx-build - not found! doc target disabled")
+endif() \ No newline at end of file