aboutsummaryrefslogtreecommitdiffstats
path: root/libpyside/CMakeLists.txt
diff options
context:
space:
mode:
authorrenatofilho <renato.filho@openbossa.org>2010-09-20 19:02:16 -0300
committerrenatofilho <renato.filho@openbossa.org>2010-09-20 19:21:33 -0300
commit2a225be9c770ccf774a97457ab409b6b3f60b467 (patch)
tree9cc2838c3c1ae1827fc23ba05291c02e6318b4cc /libpyside/CMakeLists.txt
parentf8a12b7577773f6a02804e1e60920a964f5e01ca (diff)
Use CMAKE_<CONFIG>_POSTFIX on config files, used for cmake and pkgconfig.
Fixes bug #286. Reviewer: Luciano Wolf <luciano.wolf@openbossa.org> Marcelo Lira <marcelo.lira@openbossa.org>
Diffstat (limited to 'libpyside/CMakeLists.txt')
-rw-r--r--libpyside/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/libpyside/CMakeLists.txt b/libpyside/CMakeLists.txt
index 11196f831..20bd03ac2 100644
--- a/libpyside/CMakeLists.txt
+++ b/libpyside/CMakeLists.txt
@@ -42,6 +42,12 @@ set(libpyside_HEADERS
qproperty.h
)
+if (CMAKE_BUILD_TYPE STREQUAL "Debug")
+ set(LIBRARY_OUTPUT_SUFFIX ${CMAKE_DEBUG_POSTFIX})
+else()
+ set(LIBRARY_OUTPUT_SUFFIX ${CMAKE_RELEASE_POSTFIX})
+endif()
+
# create pkg-config file
configure_file("${CMAKE_CURRENT_SOURCE_DIR}/pyside.pc.in"
"${CMAKE_CURRENT_BINARY_DIR}/pyside${pyside_SUFFIX}.pc" @ONLY)