aboutsummaryrefslogtreecommitdiffstats
path: root/libpyside/CMakeLists.txt
diff options
context:
space:
mode:
authorRenato Filho <renato.filho@openbossa.org>2011-05-19 18:12:52 -0300
committerHugo Parente Lima <hugo.pl@gmail.com>2012-03-08 16:54:25 -0300
commite13ce9212afb46f86e11f78fee98a1d1e1b1557e (patch)
tree75b6a9c5e616596b2fa5ccda2573d34f22a7dcd3 /libpyside/CMakeLists.txt
parent5805ea4e01c463e5eae029a51978bdb1b910aad4 (diff)
Implemented PySide::ClassInfo Object.
This class reproduce the Qt macro Q_CLASSINFO behavior. Eg.: @QtCore.ClassInfo(author='PySide', url='http://www.pyside.org') fixes bug #705. Reviewer: Marcelo Lira <marcelo.lira@openbossa.org> Hugo Parente Lima <hugo.pl@gmail.com>
Diffstat (limited to 'libpyside/CMakeLists.txt')
-rw-r--r--libpyside/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/libpyside/CMakeLists.txt b/libpyside/CMakeLists.txt
index c3d3f8611..2d2a61375 100644
--- a/libpyside/CMakeLists.txt
+++ b/libpyside/CMakeLists.txt
@@ -4,6 +4,7 @@ set(libpyside_SRC
dynamicqmetaobject.cpp
signalmanager.cpp
globalreceiver.cpp
+ pysideclassinfo.cpp
pysidemetafunction.cpp
pysidesignal.cpp
pysideslot.cpp
@@ -35,6 +36,7 @@ set_target_properties(pyside PROPERTIES
set(libpyside_HEADERS
dynamicqmetaobject.h
globalreceiver.h
+ pysideclassinfo.h
pysideconversions.h
pysidemacros.h
signalmanager.h