aboutsummaryrefslogtreecommitdiffstats
path: root/libpyside/CMakeLists.txt
diff options
context:
space:
mode:
authorRenato Filho <renato.filho@openbossa.org>2011-05-23 11:39:17 -0300
committerHugo Parente Lima <hugo.pl@gmail.com>2012-03-08 16:54:25 -0300
commit77559ac63945da93f7e90c2910232c6eb2629487 (patch)
treed5647375e1b48d7cef0d344433ddf9c578433829 /libpyside/CMakeLists.txt
parentd9c43275a09fc68146a210a9da281a9491d62980 (diff)
Created DestroyListener class.
This class is used to keep the Python object live until the signal destroyed emission. With this is possible to use the QObject on destruction signal. Fixes bug #505. Reviewer: Marcelo Lira <marcelo.lira@openbossa.org> Hugo Parente Lima <hugo.pl@gmail.com>
Diffstat (limited to 'libpyside/CMakeLists.txt')
-rw-r--r--libpyside/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/libpyside/CMakeLists.txt b/libpyside/CMakeLists.txt
index 2d2a61375..e05a8cd7e 100644
--- a/libpyside/CMakeLists.txt
+++ b/libpyside/CMakeLists.txt
@@ -1,7 +1,11 @@
project(libpyside)
+
+qt4_wrap_cpp(DESTROYLISTENER_MOC "destroylistener.h")
+
set(libpyside_SRC
dynamicqmetaobject.cpp
+ destroylistener.cpp
signalmanager.cpp
globalreceiver.cpp
pysideclassinfo.cpp
@@ -11,6 +15,7 @@ set(libpyside_SRC
pysideproperty.cpp
pysideweakref.cpp
pyside.cpp
+ ${DESTROYLISTENER_MOC}
)
include_directories(${CMAKE_CURRENT_SOURCE_DIR}
@@ -34,6 +39,7 @@ set_target_properties(pyside PROPERTIES
#
set(libpyside_HEADERS
+ destroylistener.h
dynamicqmetaobject.h
globalreceiver.h
pysideclassinfo.h