aboutsummaryrefslogtreecommitdiffstats
path: root/libshiboken/CMakeLists.txt
diff options
context:
space:
mode:
authorHugo Parente Lima <hugo.pl@gmail.com>2011-05-25 16:23:22 -0300
committerHugo Parente Lima <hugo.pl@gmail.com>2012-03-08 16:15:24 -0300
commit0e6d4cc1d151724f56c6ccf8c431077e2c778b26 (patch)
tree3717e96dfd1e22bc75ce409cdca20c136d056c96 /libshiboken/CMakeLists.txt
parent22bed1fb96a37bdf9d032a801f5577f81832fe76 (diff)
Added Shiboken buffer interface.
This interface is just a wrapper to the differents API's provided by Python to deal with memory buffers in various versions of Python, so is recommended to use this API to deal with Python memory buffers instead of the CPython API. If you want to have a Python buffer as argument of any function just change the argument type to "PyBuffer" and the generator will handle it right regarding to type checking. Reviewer: Renato Araújo <renato.filho@openbossa.org> Luciano Wolf <luciano.wolf@openbossa.org>
Diffstat (limited to 'libshiboken/CMakeLists.txt')
-rw-r--r--libshiboken/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/libshiboken/CMakeLists.txt b/libshiboken/CMakeLists.txt
index 0cf3f3d21..38aa46bc7 100644
--- a/libshiboken/CMakeLists.txt
+++ b/libshiboken/CMakeLists.txt
@@ -29,6 +29,7 @@ sbkenum.cpp
bindingmanager.cpp
threadstatesaver.cpp
typeresolver.cpp
+shibokenbuffer.cpp
)
include_directories(${CMAKE_CURRENT_SOURCE_DIR}
@@ -55,6 +56,7 @@ install(FILES
shibokenmacros.h
threadstatesaver.h
typeresolver.h
+ shibokenbuffer.h
DESTINATION include/shiboken${shiboken_SUFFIX})
install(TARGETS libshiboken EXPORT shiboken
LIBRARY DESTINATION "${LIB_INSTALL_DIR}"