aboutsummaryrefslogtreecommitdiffstats
path: root/libshiboken/CMakeLists.txt
diff options
context:
space:
mode:
authorMarcelo Lira <marcelo.lira@openbossa.org>2011-07-16 17:31:08 -0300
committerHugo Parente Lima <hugo.pl@gmail.com>2012-03-08 16:17:04 -0300
commit5d61dc4c2d080c1e843d8958169c924c8b31f4de (patch)
tree93d12d7e4ea333f9c55935d5b070b4e8796436d0 /libshiboken/CMakeLists.txt
parenta456b8d969eb81331cf35cfbfab8690072bae692 (diff)
Introduces new API to create and import Python modules.
The Shiboken::Module namespace also provides management of module types, including the communication of types among dependent modules. Module::create() will call Shiboken::init(), so this can be removed from the generated module's source code. This deprecates the old Shiboken::importModule() function. The generation of module initialization code was updated to use the new Shiboken::Module functions.
Diffstat (limited to 'libshiboken/CMakeLists.txt')
-rw-r--r--libshiboken/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/libshiboken/CMakeLists.txt b/libshiboken/CMakeLists.txt
index 38aa46bc7..81812e9aa 100644
--- a/libshiboken/CMakeLists.txt
+++ b/libshiboken/CMakeLists.txt
@@ -26,6 +26,7 @@ basewrapper.cpp
gilstate.cpp
helper.cpp
sbkenum.cpp
+sbkmodule.cpp
bindingmanager.cpp
threadstatesaver.cpp
typeresolver.cpp
@@ -50,6 +51,7 @@ install(FILES
gilstate.h
helper.h
sbkenum.h
+ sbkmodule.h
python25compat.h
sbkdbg.h
shiboken.h