aboutsummaryrefslogtreecommitdiffstats
path: root/libshiboken/CMakeLists.txt
diff options
context:
space:
mode:
authorRenato Filho <renato.filho@openbossa.org>2010-08-24 16:40:00 -0300
committerRenato Filho <renato.filho@openbossa.org>2010-08-25 10:38:09 -0300
commit687db5a645e4a32f47b7bc0479950c50aaca6632 (patch)
tree200c5a8273d78966ae52a16aae0c1de45e2560af /libshiboken/CMakeLists.txt
parent25dc57003ae47dd6d66cd44156872ff484868bce (diff)
Move ThreadStateSaver implementation from the header to a cpp file.
Reviewer: Luciano Wolf <luciano.wolf@openbossa.org> Hugo Parente Lima <hugo.pl@gmail.com>
Diffstat (limited to 'libshiboken/CMakeLists.txt')
-rw-r--r--libshiboken/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/libshiboken/CMakeLists.txt b/libshiboken/CMakeLists.txt
index 74d0c0219..ecdd4aafc 100644
--- a/libshiboken/CMakeLists.txt
+++ b/libshiboken/CMakeLists.txt
@@ -1,5 +1,4 @@
project(libshiboken)
-
#Find installed sparsehash
find_path(SPARSEHASH_INCLUDE_PATH sparseconfig.h PATH_SUFFIXES "/google/sparsehash")
if(SPARSEHASH_INCLUDE_PATH)
@@ -8,6 +7,7 @@ else()
set(SPARSEHASH_INCLUDE_PATH ${CMAKE_SOURCE_DIR}/ext/sparsehash)
endif()
+add_definitions(-DWITH_THREAD)
set(libshiboken_MAJOR_VERSION ${shiboken_MAJOR_VERSION})
set(libshiboken_MINOR_VERSION ${shiboken_MINOR_VERSION})
set(libshiboken_MICRO_VERSION ${shiboken_MICRO_VERSION})
@@ -26,6 +26,7 @@ basewrapper.cpp
helper.cpp
pyenum.cpp
bindingmanager.cpp
+threadstatesaver.cpp
typeresolver.cpp
)