aboutsummaryrefslogtreecommitdiffstats
path: root/libshiboken/CMakeLists.txt
diff options
context:
space:
mode:
authorHugo Parente Lima <hugo.pl@gmail.com>2010-09-20 17:26:09 -0300
committerHugo Parente Lima <hugo.pl@gmail.com>2012-03-08 16:06:00 -0300
commit7f5723eac1366e901391fb5771f4a70a45dc6932 (patch)
tree85ed4c047460cec62d8cc08d35ec4a811f96e1c1 /libshiboken/CMakeLists.txt
parent76dae669fda417b539315b9f439128f5b29c725e (diff)
Shiboken generator code moved to the directory generator.
Reviewer: Renato Araújo <renato.filho@openbossa.org> Luciano Wolf <luciano.wolf@openbossa.org>
Diffstat (limited to 'libshiboken/CMakeLists.txt')
-rw-r--r--libshiboken/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/libshiboken/CMakeLists.txt b/libshiboken/CMakeLists.txt
index bfd160b10..f21681f55 100644
--- a/libshiboken/CMakeLists.txt
+++ b/libshiboken/CMakeLists.txt
@@ -1,4 +1,12 @@
project(libshiboken)
+
+option(ENABLE_VERSION_SUFFIX "Used to use current version in suffix to generated files. This is used to allow multiples versions installed simultaneous." FALSE)
+if(ENABLE_VERSION_SUFFIX)
+ set(shiboken_SUFFIX "-${shiboken_MAJOR_VERSION}.${shiboken_MINOR_VERSION}")
+else()
+ set(shiboken_SUFFIX "")
+endif()
+
#Find installed sparsehash
find_path(SPARSEHASH_INCLUDE_PATH sparseconfig.h PATH_SUFFIXES "/google/sparsehash")
if(SPARSEHASH_INCLUDE_PATH)