aboutsummaryrefslogtreecommitdiffstats
path: root/libshiboken/CMakeLists.txt
diff options
context:
space:
mode:
authorRenato Filho <renato.filho@openbossa.org>2010-06-18 14:49:37 -0300
committerRenato Filho <renato.filho@openbossa.org>2010-06-18 15:01:24 -0300
commitd2175970450b01829c510d745c227e8b68e1f3e6 (patch)
tree62cb63b629787941f273aad931272c69b3a5715a /libshiboken/CMakeLists.txt
parent3c8595282a7ba485b464b8114e8f9adb8559eeaf (diff)
Find installed google hash library.
Reviewers: Luciano Wolf <luciano.wolf@openbossa.org>, Marcelo Lira <marcelo.lira@openbossa.org>
Diffstat (limited to 'libshiboken/CMakeLists.txt')
-rw-r--r--libshiboken/CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/libshiboken/CMakeLists.txt b/libshiboken/CMakeLists.txt
index 6b025bc73..ff15bd50a 100644
--- a/libshiboken/CMakeLists.txt
+++ b/libshiboken/CMakeLists.txt
@@ -2,13 +2,20 @@ project(libshiboken)
find_package(PythonLibs REQUIRED)
+#Find installed sparsehash
+find_path(SPARSEHASH_INCLUDE_PATH sparseconfig.h PATH_SUFFIXES "/google/sparsehash")
+if(SPARSEHASH_INCLUDE_PATH)
+ message(STATUS "Using system hash found in: ${SPARSEHASH_INCLUDE_PATH}")
+else()
+ set(SPARSEHASH_INCLUDE_PATH ${CMAKE_SOURCE_DIR}/ext/sparsehash)
+endif()
+
set(libshiboken_MAJOR_VERSION ${shiboken_MAJOR_VERSION})
set(libshiboken_MINOR_VERSION ${shiboken_MINOR_VERSION})
set(libshiboken_MICRO_VERSION ${shiboken_MICRO_VERSION})
set(libshiboken_VERSION "${libshiboken_MAJOR_VERSION}.${libshiboken_MINOR_VERSION}.${libshiboken_MICRO_VERSION}")
set(libshiboken_SOVERSION "${libshiboken_MAJOR_VERSION}.${libshiboken_MINOR_VERSION}")
-
configure_file("${CMAKE_CURRENT_SOURCE_DIR}/ShibokenConfig.cmake.in"
"${CMAKE_CURRENT_BINARY_DIR}/ShibokenConfig.cmake" @ONLY)
configure_file("${CMAKE_CURRENT_SOURCE_DIR}/ShibokenVersion.cmake.in"
@@ -26,6 +33,7 @@ typeresolver.cpp
include_directories(${CMAKE_CURRENT_SOURCE_DIR}
${PYTHON_INCLUDE_PATH}
+ ${SPARSEHASH_INCLUDE_PATH}
${CMAKE_SOURCE_DIR}/ext/sparsehash)
add_library(libshiboken SHARED ${libshiboken_SRC})
set_property(TARGET libshiboken PROPERTY PREFIX "")