aboutsummaryrefslogtreecommitdiffstats
path: root/libshiboken/CMakeLists.txt
diff options
context:
space:
mode:
authorHugo Lima <hugo.lima@openbossa.org>2009-11-23 19:35:11 -0200
committerHugo Lima <hugo.lima@openbossa.org>2009-11-23 19:35:11 -0200
commitfc9458dc83858ad76a5d589c3cd787ef5a1d5d16 (patch)
tree401c366262da8688a48efd1542630da8d093990f /libshiboken/CMakeLists.txt
parent91428f941656255f7c39f40639c0528ac7f02902 (diff)
Remove -lutil from target_link_libraries. This library *must* be provided by cmake.
If any distro doesn't provide this by default, this is a distro bug, not a shiboken one. The other problem is that an unix/linux/gcc specific flag can't be placed here, because it doesn't makes sense on windows.
Diffstat (limited to 'libshiboken/CMakeLists.txt')
-rw-r--r--libshiboken/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/libshiboken/CMakeLists.txt b/libshiboken/CMakeLists.txt
index 5118f4f5a..8f0fd7024 100644
--- a/libshiboken/CMakeLists.txt
+++ b/libshiboken/CMakeLists.txt
@@ -22,8 +22,7 @@ include_directories(${CMAKE_CURRENT_SOURCE_DIR}
add_library(libshiboken SHARED ${libshiboken_SRC})
set_property(TARGET libshiboken PROPERTY PREFIX "")
target_link_libraries(libshiboken
- ${PYTHON_LIBRARIES}
- -lutil)
+ ${PYTHON_LIBRARIES})
install(DIRECTORY . DESTINATION include/shiboken
FILES_MATCHING PATTERN "*.h"