aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorThomas-Karl Pietrowski <thopiekar@googlemail.com>2016-01-16 14:11:27 +0100
committerThomas-Karl Pietrowski <thopiekar@googlemail.com>2016-01-16 14:11:27 +0100
commit124444ccadab3f4a57b348653bd204da3b30a90a (patch)
treecc9e09413fe492e61dc5aefa88911098eedcb170 /setup.py
parent5723ad8e24c6742e1a35707f5fa7dc59062c6df4 (diff)
Updating setup.py for fixes and additions in shiboken2
This is for testing an commit for shiboken2. The changes here might be incomplete.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py20
1 files changed, 6 insertions, 14 deletions
diff --git a/setup.py b/setup.py
index 52cd56bda..0d5a320bb 100644
--- a/setup.py
+++ b/setup.py
@@ -610,24 +610,16 @@ class pyside_build(_build):
"-DCMAKE_INSTALL_PREFIX=%s" % self.install_dir,
module_src_dir
]
- if sys.version_info[0] > 2:
- cmake_cmd.append("-DPYTHON3_EXECUTABLE=%s" % self.py_executable)
- cmake_cmd.append("-DPYTHON3_INCLUDE_DIR=%s" % self.py_include_dir)
- cmake_cmd.append("-DPYTHON3_LIBRARY=%s" % self.py_library)
- if self.build_type.lower() == 'debug':
- cmake_cmd.append("-DPYTHON3_DBG_EXECUTABLE=%s" % self.py_executable)
- cmake_cmd.append("-DPYTHON3_DEBUG_LIBRARY=%s" % self.py_library)
- else:
- cmake_cmd.append("-DPYTHON_EXECUTABLE=%s" % self.py_executable)
- cmake_cmd.append("-DPYTHON_INCLUDE_DIR=%s" % self.py_include_dir)
- cmake_cmd.append("-DPYTHON_LIBRARY=%s" % self.py_library)
- if self.build_type.lower() == 'debug':
- cmake_cmd.append("-DPYTHON_DEBUG_LIBRARY=%s" % self.py_library)
+ cmake_cmd.append("-DPYTHON_EXECUTABLE=%s" % self.py_executable)
+ cmake_cmd.append("-DPYTHON_INCLUDE_DIR=%s" % self.py_include_dir)
+ cmake_cmd.append("-DPYTHON_LIBRARY=%s" % self.py_library)
+ if self.build_type.lower() == 'debug':
+ cmake_cmd.append("-DPYTHON_DEBUG_LIBRARY=%s" % self.py_library)
if extension.lower() == "shiboken2":
cmake_cmd.append("-DCMAKE_INSTALL_RPATH_USE_LINK_PATH=yes")
if sys.version_info[0] > 2:
- cmake_cmd.append("-DUSE_PYTHON3=ON")
+ cmake_cmd.append("-DUSE_PYTHON_VERSION=3.4")
if sys.platform == 'darwin':
cmake_cmd.append('-DALTERNATIVE_QT_INCLUDE_DIR=' + self.qtinfo.headers_dir)