aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorChristian Tismer <tismer@stackless.com>2016-11-03 15:59:45 +0100
committerChristian Tismer <tismer@stackless.com>2016-11-24 12:43:20 +0000
commitb4cb44bd5bdb2d4dfd9c6f0ac94242149a04d519 (patch)
tree8343aef768f9ae532b8643e9730861bab09be57b /setup.py
parent77fed7bcd5f8a666bad918ae44b6e168e07fe738 (diff)
Set the minimum Python3 to 3.3
This was not really set. The setup supported 3.2, the default was saying 3.4, and I have set it now to 3.3. Reason: Besides a sensible useful minimum version, Python 3.3.3 is the only currently working version, which allows for a debug python build on macOS. I need this for my debugging work, admittedly. So this change is really made to support PYSIDE-79. Victor Stinner has supplied a patch three years ago, see https://mail.python.org/pipermail/python-bugs-list/2013-July/209044.html Since then, the patch was not maintained, and the problem has crept into python, again. If I find some time for it, then I will fix it. Task-number: PYSIDE-79 Change-Id: I1b7d4ff1613d31567095636edc61f4222fad08dd Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 2 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 27df50a28..a0987da69 100644
--- a/setup.py
+++ b/setup.py
@@ -67,7 +67,7 @@ For development purposes the following options might be of use, when using "setu
--ignore-git will skip the fetching and checkout steps for supermodule and all submodules.
REQUIREMENTS:
-- Python: 2.6, 2.7, 3.2, 3.3 and 3.4 is supported
+- Python: 2.6, 2.7, 3.3, 3.4 and 3.5 is supported
- Cmake: Specify the path to cmake with --cmake option or add cmake to the system path.
- Qt: 4.6, 4.7 and 4.8 is supported. Specify the path to qmake with --qmake option or add qmake to the system path.
@@ -777,7 +777,7 @@ class pyside_build(_build):
if extension.lower() == "shiboken2":
cmake_cmd.append("-DCMAKE_INSTALL_RPATH_USE_LINK_PATH=yes")
if sys.version_info[0] > 2:
- cmake_cmd.append("-DUSE_PYTHON_VERSION=3.4")
+ cmake_cmd.append("-DUSE_PYTHON_VERSION=3.3")
if sys.platform == 'darwin':
# Shiboken supports specifying multiple include paths separated by a colon on *nix
@@ -1206,7 +1206,6 @@ setup(
'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.2',
'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',