aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorThomas-Karl Pietrowski <thopiekar@googlemail.com>2016-02-02 08:25:50 +0100
committerThomas-Karl Pietrowski <thopiekar@googlemail.com>2016-02-02 08:25:50 +0100
commit88307a4a8609a2aa5812c41a14e9ac1dad19b5b7 (patch)
treef79ad8db2850a77c3a7b891ab3b5ef3c675802ea /setup.py
parentb990d231810eb329d837356271a719e58a6e004d (diff)
Prefer qmake-qt5 over qmake
I tried to build pyside using setup.py here on Ubuntu and I get the same problem like mentioned in #21. The solution is to perfer qmake-qt5 over qmake. This shouldn't make any difference on OSX and Windows. Fixes #21
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 0d5a320bb..5a847527a 100644
--- a/setup.py
+++ b/setup.py
@@ -162,9 +162,9 @@ OPTION_OSXARCH = option_value("osx-arch")
OPTION_XVFB = has_option("use-xvfb")
if OPTION_QMAKE is None:
- OPTION_QMAKE = find_executable("qmake")
-if OPTION_QMAKE is None:
OPTION_QMAKE = find_executable("qmake-qt5")
+if OPTION_QMAKE is None:
+ OPTION_QMAKE = find_executable("qmake")
if OPTION_CMAKE is None:
OPTION_CMAKE = find_executable("cmake")