aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorFriedemann Kleint <Friedemann.Kleint@qt.io>2016-10-11 16:19:44 +0200
committerFriedemann Kleint <Friedemann.Kleint@qt.io>2016-10-12 08:46:27 +0000
commita2f08aa43f4d58e8e74646e50867673848077761 (patch)
treea35ed2469d5878aa66e26a6c50eb597ebde4ac07 /setup.py
parentb4a8f7345159fca93d7006d30325436fb869dc45 (diff)
Fix licenses of setup.py testrunner.py
Change-Id: I049929e2c4e24554866000df5daa063071060884 Reviewed-by: Lars Knoll <lars.knoll@qt.io>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py39
1 files changed, 39 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 59428108a..2bd0be350 100644
--- a/setup.py
+++ b/setup.py
@@ -1,3 +1,42 @@
+#############################################################################
+##
+## Copyright (C) 2016 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of PySide2.
+##
+## $QT_BEGIN_LICENSE:LGPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU Lesser General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU Lesser
+## General Public License version 3 as published by the Free Software
+## Foundation and appearing in the file LICENSE.LGPL3 included in the
+## packaging of this file. Please review the following information to
+## ensure the GNU Lesser General Public License version 3 requirements
+## will be met: https://www.gnu.org/licenses/lgpl-3.0.html.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 2.0 or (at your option) the GNU General
+## Public license version 3 or any later version approved by the KDE Free
+## Qt Foundation. The licenses are as published by the Free Software
+## Foundation and appearing in the file LICENSE.GPL2 and LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-2.0.html and
+## https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+#############################################################################
+
from __future__ import print_function
"""This is a distutils setup-script for the PySide2 project