aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2017-11-28 15:49:29 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2017-11-28 14:58:41 +0000
commit0022a9ecb7690a3bd9a7d4ce0880d1cecc937462 (patch)
tree04ee9ace512c23d374afb84fb02e860023f9b332 /setup.py
parentb6bc62550c51f2819a60a524b3b738859efa6702 (diff)
FIXUP: Make standalone option work on Linux
There was an indentation error in the rpath linux handling function, which ended up not adding any rpaths in regular builds, thus breaking PySide2 module importing. Change-Id: I18488f78aca50435f69ce091e46a77e4ec55d396 Reviewed-by: Friedemann Kleint <Friedemann.Kleint@qt.io>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index a04ad80c4..cc51ada9d 100644
--- a/setup.py
+++ b/setup.py
@@ -1435,7 +1435,7 @@ class pyside_build(_build):
qt_lib_dir = self.qtinfo.libs_dir
if OPTION_STANDALONE:
qt_lib_dir = "$ORIGIN/Qt/lib"
- final_rpath = local_rpath + ':' + qt_lib_dir
+ final_rpath = local_rpath + ':' + qt_lib_dir
cmd = [patchelf_path, '--set-rpath', final_rpath, srcpath]
if run_process(cmd) != 0:
raise RuntimeError("Error patching rpath in " + srcpath)