aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2018-02-02 16:10:23 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2018-02-06 10:48:02 +0000
commit6d04376b9993f06700df92a8d03d09b3e75f4408 (patch)
treece98b3910d2c74a863d58984433f1e8e945f4873 /setup.py
parentdce67501894f527d37447e70e17fb3bc8834ea30 (diff)
Add setup.py option to output compiler command line invocation
Useful for debugging incorrect command line arguments (especially for CI builds). Change-Id: I2c291c1ede5c2e17cdd877f788e8b62876568367 Reviewed-by: Friedemann Kleint <Friedemann.Kleint@qt.io>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 5 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index e4e9a88d9..5855d6f8f 100644
--- a/setup.py
+++ b/setup.py
@@ -80,6 +80,7 @@ For development purposes the following options might be of use, when using "setu
--skip-make-install will not run make install (or equivalent) for each built module,
--skip-packaging will skip creation of the python package,
--ignore-git will skip the fetching and checkout steps for supermodule and all submodules.
+ --verbose-build will output the compiler invocation with command line arguments, etc.
REQUIREMENTS:
- Python: 2.6, 2.7, 3.3, 3.4, 3.5 and 3.6 are supported
@@ -272,6 +273,7 @@ OPTION_SKIP_PACKAGING = has_option("skip-packaging")
OPTION_RPATH_VALUES = option_value("rpath")
OPTION_QT_CONF_PREFIX = option_value("qt-conf-prefix")
OPTION_ICULIB = option_value("iculib-url")
+OPTION_VERBOSE_BUILD = has_option("verbose-build")
# This is used automatically by distutils.command.install object, to specify final installation
# location.
@@ -921,6 +923,9 @@ class pyside_build(_build):
if self.build_type.lower() == 'debug':
cmake_cmd.append("-DPYTHON_DEBUG_LIBRARY=%s" % self.py_library)
+ if OPTION_VERBOSE_BUILD:
+ cmake_cmd.append("-DCMAKE_VERBOSE_MAKEFILE:BOOL=ON")
+
if extension.lower() == "pyside2":
pyside_qt_conf_prefix = ''
if OPTION_QT_CONF_PREFIX: