aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2017-08-23 16:47:14 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2017-08-24 10:30:18 +0000
commit91d37a1381b77c12a1c99ea43f5b1bf464a0ff40 (patch)
tree2ff4ebc148d34dbede569533fbfc4d7e3eee8169 /setup.py
parent8aca0dec116c6b321373f5636b34036530ac6e4b (diff)
Streamline Qt5 detection on macOS
This consists of a few things: - Remove the detection and usage of ALTERNATIVE_QT_INCLUDE_DIR in setup.py, because CMake takes care of finding the correct Qt include headers. - Add detection of framework / non-framework includes in the CMake rules, instead of in the setup.py script. - Don't pass QT_QMAKE_EXECUTABLE from setup.py to CMake, because it is not being used. It was previously used for detecting Qt4 via the CMake FindQt4.cmake file. Now it is done by find_package() which detects qmake from the environment. - Get rid of the old "/Library/Frameworks" QT_INCLUDE_DIR, which was where the official Qt 4.8.x packages installed Qt. - Deprecate usage of ALTERNATIVE_QT_INCLUDE_DIR. Now it is only used if CMake fails to detect the proper include headers of Qt5 (which should not happen). Change-Id: I829b92bc0d40ae7eb418be27c735fc095e557820 Reviewed-by: Christian Tismer <tismer@stackless.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py13
1 files changed, 0 insertions, 13 deletions
diff --git a/setup.py b/setup.py
index af33254ca..ce67ef942 100644
--- a/setup.py
+++ b/setup.py
@@ -801,7 +801,6 @@ class pyside_build(_build):
cmake_cmd = [
OPTION_CMAKE,
"-G", self.make_generator,
- "-DQT_QMAKE_EXECUTABLE='%s'" % self.qtinfo.qmake_command,
"-DBUILD_TESTS=%s" % self.build_tests,
"-DQt5Help_DIR=%s" % self.qtinfo.docs_dir,
"-DCMAKE_BUILD_TYPE=%s" % self.build_type,
@@ -823,18 +822,6 @@ class pyside_build(_build):
cmake_cmd.append("-DUSE_PYTHON_VERSION=3.3")
if sys.platform == 'darwin':
- # Shiboken supports specifying multiple include paths separated by a colon on *nix
- # systems.
- # In a framework build, two paths should be included:
- # path_to_qt/lib -> which contains framework folders with headers, and
- # path_to_qt/include -> which contains headers for static libraries.
- # A non-framework build contains all headers in the path_to_qt/include folder.
- path_separator = ":"
- includes_dir = '-DALTERNATIVE_QT_INCLUDE_DIR=' + self.qtinfo.headers_dir
- if os.path.isdir(self.qtinfo.headers_dir + "/../lib/QtCore.framework"):
- includes_dir += path_separator + self.qtinfo.headers_dir + "/../lib/"
- cmake_cmd.append(includes_dir)
-
if OPTION_OSXARCH:
# also tell cmake which architecture to use
cmake_cmd.append("-DCMAKE_OSX_ARCHITECTURES:STRING={}".format(OPTION_OSXARCH))