aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2017-04-28 15:42:43 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2017-04-28 15:30:53 +0000
commita2fb6b15a9542e2e6bfeaf3104f0c9e2dd77d00d (patch)
tree127dcd43bd1ddb2a89ebe433a36b00ee8215d4e3 /setup.py
parent898620ed8b4df90f7f8d8d8284937a11658e2fa7 (diff)
Fix CMake bug where incorrect CMAKE_OSX_SYSROOT was chosen
Apparently in earlier versions of CMake, if the OS version found in CMAKE_OSX_DEPLOYMENT_TARGET did not have a corresponding SDK with the same version in XCode, the CMake build would fail. Make sure to use the latest SDK available to XCode. Change-Id: Ie2317c1d285377b0cd5c7a75c94628b03aef557e Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Christian Tismer <tismer@stackless.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 6 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 885ab9865..da11ad0ca 100644
--- a/setup.py
+++ b/setup.py
@@ -825,6 +825,12 @@ class pyside_build(_build):
if OPTION_OSX_SYSROOT:
cmake_cmd.append("-DCMAKE_OSX_SYSROOT={}".format(OPTION_OSX_SYSROOT))
+ else:
+ latest_sdk_path = run_process_output(['xcrun', '--show-sdk-path'])
+ if latest_sdk_path:
+ latest_sdk_path = latest_sdk_path[0]
+ cmake_cmd.append("-DCMAKE_OSX_SYSROOT={}".format(latest_sdk_path))
+
if not OPTION_SKIP_CMAKE:
log.info("Configuring module %s (%s)..." % (extension, module_src_dir))