aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2018-04-23 13:00:49 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2018-04-25 06:30:20 +0000
commit0b842db3a95a44fbda3379d2093cb52f8ae2a1ff (patch)
treea8013d34a7e6037ca6d510ae48a2deeb5e1555a5 /setup.py
parentd6143cf77b3e28945768596f671418623da02a43 (diff)
Remove deprecated options
Change-Id: I0ea2b56778b2364a25f6999c2c18ef0c0a436583 Reviewed-by: Friedemann Kleint <Friedemann.Kleint@qt.io>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 0 insertions, 8 deletions
diff --git a/setup.py b/setup.py
index 8da8c70e2..5b1faf0ff 100644
--- a/setup.py
+++ b/setup.py
@@ -337,8 +337,6 @@ OPTION_CMAKE = option_value("cmake")
OPTION_OPENSSL = option_value("openssl")
OPTION_ONLYPACKAGE = has_option("only-package")
OPTION_STANDALONE = has_option("standalone")
-OPTION_VERSION = option_value("version") # Deprecated
-OPTION_LISTVERSIONS = has_option("list-versions") # Deprecated
OPTION_MAKESPEC = option_value("make-spec")
OPTION_IGNOREGIT = has_option("ignore-git")
# don't include pyside2-examples
@@ -363,7 +361,6 @@ OPTION_MODULE_SUBSET = option_value("module-subset")
OPTION_RPATH_VALUES = option_value("rpath")
OPTION_QT_CONF_PREFIX = option_value("qt-conf-prefix")
OPTION_QT_SRC = option_value("qt-src-dir")
-OPTION_ICULIB = option_value("iculib-url") # Deprecated
OPTION_VERBOSE_BUILD = has_option("verbose-build")
OPTION_SANITIZE_ADDRESS = has_option("sanitize-address")
@@ -437,11 +434,6 @@ if OPTION_JOBS:
else:
OPTION_JOBS = ''
-if OPTION_ICULIB:
- if not OPTION_STANDALONE:
- print("--iculib-url "
- "option is a no-op option and will be removed soon.")
-
def is_debug_python():
return getattr(sys, "gettotalrefcount", None) is not None