aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorFriedemann Kleint <Friedemann.Kleint@qt.io>2020-10-28 07:51:22 +0100
committerFriedemann Kleint <Friedemann.Kleint@qt.io>2020-10-28 09:34:35 +0000
commit2a2a0827fa54b2eeb48e0e2090dfc503492ef33e (patch)
tree4311f7ad34ff98fabcbe4c34e59a970ae4ff4bcf /setup.py
parentfb1c0f204e09ba29fa3d360d72231d4ed468c1e4 (diff)
Rename shiboken2 to shiboken6
Adapt CMake files, build scripts, tests and examples. Task-number: PYSIDE-904 Change-Id: I4cb5ee4c8df539546014b08202a7b1e98ed3ff07 Reviewed-by: Cristian Maureira-Fredes <cristian.maureira-fredes@qt.io>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py14
1 files changed, 7 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index 8eb2027b6..c6cd382b5 100644
--- a/setup.py
+++ b/setup.py
@@ -42,7 +42,7 @@ from __future__ import print_function
"""
This is a distutils setup-script for the Qt for Python project
-To build both shiboken2 and PySide2 simply execute:
+To build both shiboken6 and PySide2 simply execute:
python setup.py build
@@ -54,8 +54,8 @@ to build and install into your current Python installation.
The same setup.py script is used to build all the components of the
project:
- - shiboken2 (the supporting Python module)
- - shiboken2-generator (the bindings generation executable)
+ - shiboken6 (the supporting Python module)
+ - shiboken6-generator (the bindings generation executable)
- PySide2
- pyside2-tools
@@ -75,8 +75,8 @@ By default, all of the above is built when no special options are
passed to the script. You can use the --build-type parameter to specify
which things should be built:
- --build-type=shiboken2 - build / package only the python module
- --build-type=shiboken2-generator - build / package the generator
+ --build-type=shiboken6 - build / package only the python module
+ --build-type=shiboken6-generator - build / package the generator
executable
--build-type=pyside2 - build / package the PySide2 bindings and
and pyside2-tools
@@ -84,11 +84,11 @@ which things should be built:
When building PySide2, optionally, one can specify the location of the
-shiboken2 cmake config path if it is not on the current PATH with:
+shiboken6 cmake config path if it is not on the current PATH with:
--shiboken-config-dir=/path/to/shiboken/cmake/config/dir
-This is useful if you did a cmake installation of shiboken2 into
+This is useful if you did a cmake installation of shiboken6 into
a custom location.
For Windows, if OpenSSL support is required, it's necessary to specify