aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorRoman Lacko <backup.rlacko@gmail.com>2012-06-20 16:49:18 +0200
committerRoman Lacko <backup.rlacko@gmail.com>2012-06-20 16:49:18 +0200
commita45501d6f78c0dd3a37282ccd7f92c7dae46e112 (patch)
treedb6a4b90d0e8dae2f9203b4abd95f859b4b91e06 /setup.py
parenta99ef8ddc8ed81ed4b0fa4615d1c066c5d18d145 (diff)
fix submodule initialization
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 3eb1aed34..581859cc8 100644
--- a/setup.py
+++ b/setup.py
@@ -101,6 +101,9 @@ for pkg in ["PySide", "pysideuic"]:
# Ensure that git submodules are initialized, if this is the git repo clone
if os.path.isdir(".git"):
print("Initializing submodules for PySide version %s" % __version__)
+ git_update_cmd = ["git", "submodule", "update", "--init"]
+ if run_process(git_update_cmd) != 0:
+ raise DistutilsSetupError("Failed to initialize the git submodules")
git_pull_cmd = ["git", "submodule", "foreach", "git", "pull", "origin", "master"]
if run_process(git_pull_cmd) != 0:
raise DistutilsSetupError("Failed to initialize the git submodules")